When I import any model, Unity automatically applies a smooth affect.

Occasionally this effect is wanted, but on other models I really don't want it. How do I stop it?

If you have the normals for the model set to calculate in the import settings, change the smoothing angle as desired. If you have them set to import, you handle it in your 3D app. (In Blender, for example, the easiest thing to work with is the edge split modifier.)