When I import my sprites into the game, they look terrible. How do I fix this?

When I import my sprites in, they look great close up but terrible when zoomed out. However, this is only true within unity. In photoshop, where I created them, they look fine no matter how far away or close up I am. Mip maps are on, but without them the sprites look even worse. I turned compression to none, and set the max size to 4096 to ensure no resizing. The images I am attaching is a little smaller than in game just because of the size requirements of unity forums. The files are the original sprite I made in photoshop and what it looks like in play mode.

Don’t zoom in your game view with “scale” slider at the top, always leave it at 1x. It acts as though you took a screenshot and zoomed in, which decreases the quality.

You can also mess with anti-aliasing settings. Also if you’re using photoshop format for sprites, check the “remove matte” option in sprite import settings.