whhy does unity mess with my blender model like this?

when i import a blender model into unity i have issues with the animation. it looks fine in blender, but when it is imported it gets all messed up.

mind you i already turned off the re sample curves option in the inspector which is what other forums told me to do.

left is what it looks like in blender, and right is what unity does to it…

Unity only supports up to 4 blendweights per vertex, So if you assign more than 4 bones to a single vertex, only 4 will be used. As qobion said in the comment, Unity may even use less bones depending on the quality settings. For mobile builds the usual bone count is 2. So even 4 bones may be assigned to a vertex, only two with the highest weight will be used. Skinning is a quite expensive task. That’s why Unity only supports 4 bones per vertex. For most animations this should be enough.

@nric2001 make sure it’s a fbx because unity isn’t the best with blend files… i had how the same problem before. also make sure unity isn’t optimizing it… it should matter but just check to see if it changes.