White Screen

I am ULTRA new to unity and when I installed it I tried loading the editor but its just a white windowed screen with nothing is there something I am missing??? SO FRUSTRATING!

The fix for me was turning off my VPN software.
I tested it a few times and every time when the VPN software was running (and connected) Unity opened slow(er) and got stuck on the white screen… (crash?)
When the VPN was off, everything acted like normal.

Same problem. So far, research shows that there are no solutions. Just people suggesting that we look for them.

My version of Unity worked until a few weeks ago.

Bug reported.

Edit for clarification: this seems to be some kind of display issue. When I move my mouse around the screen, the cursor will change indicating that the window actually has content. I can interact with the contents, just not SEE them.

Just a shot in the dark.
Open up your Unity Shortcut File directory, right click and select “Properties”. Must be the Shortcut, not the executable. At the end of “Target”, paste in “-force-d3d9”. This solved a multitude of my issues for visual bugs.

Please help I really just want to get into the coding but it really doesn’t work!

I have never had this problem, but I know quite a few others have, so you should try to do research about how others handled this. If nothing helps, post your editor log or contact support.

Same Question. I installed Unity 2017.10f3 version. When I opened it for the first time it just got halted on the white screen. I closed it and opened again still it gets stuck at the white screen. Even re-installing it didn’t help. Any suggestions?

I was struggling with this issue the whole day. On friday Unity worked without any problems. Today it was just white with the menue bar on top. I could click around and the dropdowns worked, yet not alot more.

I have tried everything I could find on the internet. Every single suggestion. Nothing helped. Nada.
Then I looked into my app list and got reminded, that I had installed Minecraft at the weekend. After uninstalling Minecraft Unity worked again like a charm. Sounds silly, but maybe someone else can benefit from this. Did cost me almost a whole working day.

Edit: I tried to find out what might have been the problem with Minecraft. So I realized that I had installed the Java version of it. I have downloaded the Windows 10 Version of Minecraft and with this Unity still worked properly. So I suppose this might be a Java issue and it could also come to conflicts with other apps based on Java. Only my thoughts - no guarantee.

Attempt do delete and reinstall Unity. If Unity still does not work then check your task manager to see if your computer can handle Unity. @JLionStudios

Hello, I installed Unity 2017.10f3 version. When I opened it for the first time it just got halted on the white screen. I closed it and opened again still it gets stuck at the white screen. Any suggestion for this ??

Install this update:

Microsoft Learn: Build skills that open doors in your career. try installing this update:

tl;dr;. try renaming your Library folder of the offending project (e.g. to _Library or Librarybackup) and then loading the project. Unity should try to re-make Library. IF all goes well, you can delete your renamed _Library folder and get on with your work :slight_smile:

For those using Linux and/or storing your projects in a local git repo, I found this solution solved this white-screen-on-project-load issue

Unity crashed (shocker, right?). I rebooted and whenever I tried to load that project it would get hung up with a white screen. I could open other projects. I renamed the library folder to LibraryBackup just in case. Then it worked fine. It took a while to created a new Library folder but you could see the menu popup creating and importing assets (as opposed to before when it didn’t do anything). I then just deleted the renamed library folder. So unity must have messed up some files when it crashed.

[thanks to @WhereTheIDivides .]

Just a few notes about my exact bug:

  • It’s not a compatibility thing, as I had literally created the project within this same unity version (2018.2.0b7) only a moment earlier
  • no errors were being reported, just a white screen where the editor should have been, with only the File, Edit, Assets … etc showing.
  • I don’t recall unity every crashing on me today, but maybe it did in the background?
  • I have a suspicion that git might have had something to do with it, as I have set unity up to make new projects under a massive local git repository, and I had also made some huge changes to it 15 mins before this bug occurred [although I did reboot, so I don’t know why they would cause a bug]

fix for me was: right click on the desktop and select ‘nvidia control panel’ then on the left side select Manage 3D settings → then in the main window under ‘select a program to customize’ select unity 3d, if its not there then click ADD and add untiy, Under 'Select the preferred graphics processor for this program-> select Integrated graphics… then start unity again…
This did it for me