Why am I missing the In the Cloud option?

I am one of multiple students working on a project for school. As such, the teacher has set up a collaboration for us to use. I know I have been invited to the both the organization and the project, as I am very clearly able to view this on my account on Unity’s website. When I open Unity itself (which is version 5.4.1), I am supposed to be able to see an option labelled “In the Cloud” like the rest of my class, but I do not have that appearing for me.

I don’t exactly know where the issue here lies, but it is readily apparent that I can’t access the cloud files from my Unity. This has been an issue I’ve tried figuring out both on my own, with the teacher, and with other students, but nothing I do changes this. I can confirm I am a part of both the organization and the project, even listed as a user, but I have absolutely no way of accessing Cloud files from my Unity client and I have no idea why. Any help would be greatly appreciated.

Same issue here. Did you fixed it?

If you’re talking about Unity Collaborate, that has a minimum requirement of Unity 5.5 or higher.