Why are my particles getting bigger?

Hey people!

Why are my particles getting bigger when I move away from them? Its really annoying me... Please answer my question.

Thanks in advance...

If the sizes of your particles are limited by the Max Particle Size setting in the Particle Renderer, then they can appear as if they are getting bigger when they are further away, because they keep the same size on the screen. Try to set Max Particle Size to a really large number and see if the problem disappears.

Hi, all the answers online did not help me, but finally I found the solution:
The thing is: Min Particle Size and May Particle Size Settings will not affect your particles as desired as long as “Billboard Alignment” is set to “view”!

So if you want that your partciles in Unity keep a constant, absolute size (= size of particle in the world, not relative to the camera or viewport), set Billboard Alignment to “Facing”.

Also check all the aother parameters shown in the following screenshot, because they may interfere with your particle size if configured the wrong way!

Hope this helps!

Do you have a value entered for particle grow?