Why are my shadows on my meshes, flat?

All shadows on the object are just 1 color. There’s nothing special about the shader, it’s just a lambert and it doesn’t change when I change shaders. I messed all with the quality settings, all light settings, fog settings, ambient settings, rendering settings, I don’t know what’s causing it.

Here’s an image of what I have with lights on and lights off. Then the last image is the mesh placed in a new scene with 1 directional light (this is the result I want)

The left most image shows the back side of the object, with the directional light shiny from the front. Try rotating the directional light and see how this affects the object.