Why built-in MonoDevelop for Unity doesn't launch?

Basically I’ve described my problem, so I can’t edit a script now.

I had the same problem. Try holding down the key with the Windows icon and repeatedly pressing on the left or right arrow keys. It may be off the screen. I’ve only ever had this problem in Monodevelop.

I already know the answer, guys, thank you all. It’s because I didn’t have Microsoft .NET Framework installed on the computer. It is necessary to support all kinds of script writing.

Well (I know this is a stupid question) did you install it with your unity package? If so then try re-installing unity all together. That might fix your problem.

Well, yes, I did. And I re-installed it then. It just doesn’t run.
Should I get a new MonoDevelop separatelly from Unity?

Did you check that it is set in Edit->Preferences… [General]/External Script Editor?

If not, you should click on Browse… and reset the location of MonoDevelop binary (this should be in Unity/MonoDevelop/bin).

I have same problem. A month ago I didn’t have this problem. When I tried to open script from Windows it says it is not System32 program. I have win xp sp3.

I had the same problem. Try holding down the keyboard key with the Windows icon on it and repeatedly pressing the left or right arrow keys. FOr some reason, when Monodevelop launches, sometimes it launches itself on some phantom extra monitor.

Check the log at:


If i install Unity under non-admin account on Mac OS i unable to use MonoDevelop until i run following command in Terminal:

sudo chgrp -R staff /Applications/Unity/MonoDevelop.app

The problem I was having was it would show the mono splash screen but not open Mono. Checking task manager showed there were two instances that were showing to be running but there was no instance on the task bar even thought it is pinned there. I ended task on the two running instances and it worked.

I have had to do this many times since but it works every time. Hopefully this helps some people because I could not find anything online while I searched and figured it out on accident. I don’t know why the instances are getting stuck but they are.

one other possible solution: Grab GTK# from MonoDevelop’s homepage and install it.