Why can't I get snapping to work? (Mac)

Reeeaally new to Unity, and just following a video tutorial.

For some reason I cannot get snapping to work. I have set my snap settings under the Edit menu, and in the video it shows that, when you then move or rotate an object, it snaps.

Doesn’t happen for me - whatever my snap settings, when I move or rotate the object, it does it in the smallest increments, no snapping.

The video tutorial covers Windows - I’m on Mac. Is there something silly I’m missing, like a key I should be holding down as I drag? (I’ve tried this, too, and same result).

On the Mac you must hold the Command ⌘ key to perform snapping.

See: Unity - Manual: Position GameObjects

Note: On Windows you use the Control key.

Another thing that can stop scene view objects/sprites from snapping and or rotating is if they are part of a hierarchy. In 2D mode, if the rectangular transform button mode is not working how it should, try dragging the child object you are trying to rotate outside of the hierarchy (not underneath and indented under another game object)

.

You can rotate in rectangular transform mode by hovering your mouse cursor just above the corners to see a rotation/refresh symbol.

.

If you see no axis or blue dots and snapping isn’t working try restarting Unity. That usually will make the scene view work better when it is acting up. In november 2018, I can’t get z-axis snapping to work for 2D sprites to work at all, so you will manually have to round the z-transform.

@Mitya I had the same problem when trying to use the UI move tool (looks like a box with a circle in the middle). I was able to get snap ctrl-dragging working using the regular move tool (looks like a cross with arrows), dragging the axis gizmos.

Holding Control or Command should work, but if you want it always on you can use ProGrids.

If you install ProGrids the third option on their toolbar enables snapping all the time without holding down Control.

See the blue buttons on the left. The third one toggles Snapping to grid.

158382-progrids-screenshot.jpg

https://unity3d.com/unity/features/worldbuilding/probuilder

https://docs.unity3d.com/Packages/com.unity.progrids@3.0/manual/install.html