Why can't I see my objects in the scene view when adding a background image and a background camera?

I followed all the instructions proposed by Duck in a previous thread about having a background image and a background camera. These were the instructions:

-Create a new camera (GameObject -> Create Other -> Camera), and name it "Background Camera".

-Create a new GUI Texture (GameObject -> Create Other -> GUI Texture), and name it "Background Image".

-Click the "Layer" dropdown menu in the Background Image's inspector pane, and select "Add Layer".

-In the next free "User Layer" slot, create a new layer name called "Background Image". This will be directly under the layer named "Terrain" if you haven't yet added any others. Select your Background Image in the hierarchy, and give it the desired texture, and set the x, y, width and height under "Pixel Inset" so that it fills the screen appropriately.

-Near the top of the inspector window, Use the layer dropdown menu to assign your "Background Image" layer that you defined earlier to this gameobject.

Now select your Background Camera in the hierarchy, and adjust these settings in the inspector:

-Un-Check Flare Layer and Audio Listener (but leave GUILayer enabled)

-Set Clear Flags to Solid Color

-Set Depth to -1

-Set Culling Mask, first to "Nothing", and then to "Background Image"

-Now Select you other (main) camera, and in the inspector:

-Set its Clear Flags to "Depth Only"

-Click its culling mask setting, and un-check "Background Image". This should result in the culling mask displaying as "Mixed ..."

As mompoleon mentionned, I have the same problem: I can't see the objects in the view scene.

Thanks in advance!

Just realised it was working fine - something had been unchecked. Sorry about that!