Why can't I select Android Minimum API Level?

I can’t select Minimum API Level under android settings, it’s just a greyed out “Getting API levels…” I need to set it for AR Foundation. Trying to build and run anyway I get error “ARCore Required apps require a minimum SDK version of 24. Currently set to AndroidApiLevel16.” Helpp.

Ok I was facing this issue and I found out that it was the company proxy that kinda hindered the SDK Manager to fetch info from repositories.

So if you’re behind a proxy, this is what you should do.

First, I already had a previous Android installation which could access the repos via Android Studio, however it seems that Android studio adds the correct input variables to SDK manager if Android Studio itself has a proxy setup.


  1. Enter your installation folder and navigate to the map where you have your SDK installed. Mine was something like this: “\Editor\2019.2.1f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK”

  2. Enter “tools/bin”, you should find the “sdkmanager.bat” there.

  3. Duplicate “sdkmanager.bat”. and rename it to something like “sdkmanager_untouched.bat” (For safekeeping in case everything fails)

  4. Open the “sdkmanager.bat” in a Wordpad or Notepad++ or something similar of your choice

  5. Edit the bat file in the appropriate places, I added the PROXY_VARIABLES and modified the DEFAULT_JVM_OPTS, don’t forget the whitespaces, especially in PROXY_VARIABLES:

Also don’t forget to pass them on:

Note the "%PROXY_VARIABLES% in the ending there. So that should make the sdkmanager.bat file proxy safe. This is because Unity does not support proxy settings, talk about a hassle …

Same here138867-capture.png

Any Answer?

facing same issue with 2019.3.0a12. any fixes ?,Facing same issue for unity 2019.3.0a12. Any fixes for this ?

Thanks @Mazzeman!

you can edit file in: /ProjectSettings/ProjectSettings.asset
there’s a property named AndroidMinSdkVersion change the value to any minimum API level you want.

problem fixed here : Target Api Level Getting Api Levels Unity - YouTube