why can't see UI elements in scene view

My problem is ( as illustrated below ) that none of the UI elements are showing up in scene view. All i can see is the boundaries provided by the rectangular tool.

Every other thing is working as expected.

Am I missing something?

35147-ss.jpg

I tried reinstalling Unity, but it didn’t solve the problem.
My current version is 4.6.0f1, but I had the same issue with older versions as well.
I’m running Unity on Windows 7.
I have an Ati HD4300 videocard if that’s relevant (can’t guess how…).
Thanks for helping!

I solved with selecting Layer menu in the top right corner of unity, check on the relative layer(UI layer). Hope this helps.

57947-screenshot-1.png

JUST PREES ON LAYERS

Hey guys !
I had the same issue and none of the solutions above seemed to work. Then I just remembered that for an obscure reason you have to unzoom a lot in your scene.

All the UI’s elements are way much bigger than your actual scene size.

Hope this helps.

I couldn’t solve it with upgrade to 5.0.2f1 but i saw the answer of “selecting Layer UI” and this didn’t work for me however I selected Default layer and it worked

For anyone who has this problem, and yes its not the zoom, nor the Layers dropdown at the top right, nor the zOrdering of the canavas / camera

I founds this!
if you are using the new Rendering Pipeline, URP, HDRP , LWRP. check the settings at your forward renders, it must have UI and Transparent layer assigned to the transparent layer dropdown!

Like this

also need select “UI” option on “Layers” of top right 。
just now i fix it

Update to 5.0.2p4 helped for me.

You need to select an object on the scene before attempting to add a UI Component to it. If you want to create a UI object directly, go to GameObject → UI

If UI element is an Image, you may have set myimage.enabled=false in the update() method.

Although the checkbox next to “image” component would be unchecked in editor, which it doesn’t appear to be in your case.

May help someone else, though.

I just fixed it by raising the Sort Order level on the Canvas itself. I hope it will be of any help.

I had the same problem with Unity 2017, and by switching to 2D mode and zooming about a bit, the problem is gone.

Found another reason this might happen. Just having elements in the Scene is not enough for them to be visible. You have to make sure they are also inside the Canvas item in the scene hierarchy!

OMG this also happens to me on 2021.3.0f1, i was going crazy until I see this post, thanks!

Hi, I have unity 5 2d project, I can not open UI components

. Do i need to import something? How can I make it work.