Why CTRL + C / CTRL + V not work in mono develope?

Yesterday I install new version of Unity and find that CTRL + C / CTRL + V not work in mono delope(but CTRL + Z work correctly ). My windows is russian, In all previos version of Monodeveloper CTRL + C / CTRL + V nor work only if selected russian language, but now CTRL + C / CTRL + V with any language. How can i fix this?

It also happens to me, most of the time specially when i copy outside monodevelop and paste it inside monodevelop.

what i do is press CTRL+C (copy) inside monodevelop before i do CTRL+C anything outside Monodevelop

It’s a stupid bug, and I find a way to solve it.You can solve follow this steps:

  1. paste the text to the search input field
  2. select all the text in the search input field and copy it again
  3. paste the text at the place you want

It’s a weird bug,sometimes happens to me,all i could do is to save all the things that i made and then restart my computer(or restart monodevelop).First try if the copy/paste(Ctrl + C/V) works on notepad(or similar programs),then if it works on notepad then monodevelop has a bug,if not that could be a system error.

It might not be working because you have caps lock on.

By the way, monodevelop is extremely buggy. And to top it off, it’s not even consistent with its bugs. They’re pretty random. I recommend you switch to Visual Studio 2013. It’s free and actually reliable.

Not sure why it happens but it does happen, sometimes quite often. Closing and restarting Monodevelop solves the problem for me.

No only in Mono, in Unity too, in animation window. Sometimes no copy paste and I need restar Unity… is a bad bug.

When ctrl C and ctrl V don’t work, use the right click mouse menu for copy and paste. After you do this, ctrl C and ctrl V will work again…at least it does here.

I instead switched to Microsoft visual studio, It seems way better because it automatically suggests how to fix your errors (It’s not Always the best option to use the error fixes though!) and it saves A LOT of compiling time for me and it actually shows you exactly where it is.

I don’t know why so happens… I have the same problem too… I have to rebinding some combinations in “Key Bindings” (MonoDevelop Window → Tools → Options → Environment → Key Bindings). So instead default hotkeys I use this:

Undo: Ctrl + Z is now Alt + , (Corner is also “<” on the keyboard)

Redo: Ctrl + Y is now Alt + . (Dot is also “>” on the keyboard)

Copy: Ctrl + C is now F1 (Save your progress as in ePSXe emulator :slight_smile: )

Paste: Ctrl + V is now F3 (Load your saved progress :slight_smile: )

Hope this solution will be useful :slight_smile: