Why did my Transform Component stop using degrees for rotation

The transform component on all of my gameobjects, prefas, and everything has changed, well, just the rotation part has. It is no longer in degrees but in some other variable. Instead of just an X, Y, and Z variable that can be manipulated, there are X, Y, Z, and a W. The variables are not in degrees, for example, if I want to change something by 90 degrees, I have to change it to 0.7 or -0.7. This is really getting on my nerves, I have tried removing the few plugins I have, I have tried reimporting everything. It is only in this project, I have another project where the transform component uses degrees. So it is something with my other project. Any and all help is appreciated. Thanks.

Change the inspector from debug mode back to normal mode.

You probably have a custom inspector in your project which replaces the default inspector for the Transform component. You can find it by using MonoDevelops search function. Choose “search in files” and select “whole solution”. Search for those terms one by one:

  • CustomEditor(typeof(Transform)
  • CustomEditor(Transform
  • CustomEditor(typeof(Component)
  • CustomEditor(Component

If non is found there might be some spaces before / after the brackets. In this case it’s better to just search for

  • CustomEditor

To get all custom inspectors and check them manually if one of them is directly or indirectly used for the Transform.