Why do colliders slightly clip through each other?

they don’t.

I don’t know what you have wrong by that is way too much clipping.

Either you dont have a rigidbody or your colliders are different sizes than your cubes. you’d need a screen shot showing your colliders on both objects and showing they have rigid bodies andd stuff.

I don’t know what your scale is here, but there is a setting for the physics engine that allows a small bit of penetration: Min Penetration for Penalty.

Go to Edit/Project Settings/Physics and set this value to 0.0. You may get more jitter with your physics interactions with this value set to 0.0.