Why do dynamic shadows not get batched?

Does anyone know why dynamic shadows don’t get batched when all objects in the scene otherwise have no problem with batching? To see the issue just create a plane with “receives shadows” enabled, a directional light, and a bunch of “static” objects above the plane. Now turn shadows on and off for the light. I get like 3 draw calls with shadows off, but with shadows on there is one extra draw call per object above the plane. Unity creates just one scene-wide shadow map (i.e. not one per light), right? You can also disable “receives shadows” for the static objects and and still won’t reduce the number of draw calls.

Isn’t this because of cascaded shadow maps that render the objets in different cascades ?? Like if you have 2 cascades then the object will be rendered twice…