Why do I get a lights warning when I am using no lights???

I have a scene where I am not using any lights but I get this message again and again. Also, I have oddly poor performance that I am wondering if it might be related to this warning.

"Warning! Using more than 1 pixel lights on a mobile device may decrease performance severely. You can change the mobile quality settings in 'Project Settings -> Quality Settings'."

Any way to deal with this?

I was having this problem, too, but it seems that the warning isn't about the number of lights actually in the scene, but the number of potential pixel lights. Going to the Quality Settings (Edit->Project Settings->Quality) will let you reduce the allowed pixel lights in the scene by either reducing the quality of the "Default Mobile Quality" (e.g., to Simple) or reducing the pixel light count in whatever quality setting you're using.

I don't know, i have the same problem :(

but it was since the update to the version of "Unity 3.3.0f4"

Do follow Kevin 5’s advice, it fixes the problem. I just ran into the same issue building a scene for iOS that had only a single light; the default quality settings for mobile is “Good” and that allows for a maximum of 2 pixel lights, and that’s really what Unity is warning you about, regardless of how many actual lights you have in your scene. Either choose the first quality level below Good that allows only 1 pixel light or change Good to that setting and I promise you the warning will disappear.

HTH!

  • jmpp