Why do obejcts fade when farther from the camera when using URP?

This is the default scene when starting a project with URP, I only added the cube.

This is what it looks like when zoomed in.

This is what it looks like when zoomed out.

When the camera is farther away the objects are clearly faded. Why is this happening and how can I change this behavior?

It’s because Fog is turned on by default in the URP Template.
To disable it, proceed to: Window → Rendering → Lighting → Environment Tab → Other Settings. There you can turn the fog off.