Why does same Windows Store build look better on PC than tablet?

So I have my quality settings set to excellent and I’ve forced shadows to extra high res. and set 8x AA. I build for Windows Store, and when I run that same build on my PC (as a store/metro app, not standalone) the shadows look much better than when I run the same build on my Surface 2 tablet. Is this because the shadows or something else is controlled by the display hardware/drivers, in which case I have no control over it? Or is there some setting in Unity that I’m missing? I don’t see any settings that are different for tablets vs desktops, for Windows Store. Or maybe a Visual Studio setting?

As you can see both are the same resolution, 1080HD (yes, Surface 2 is HD now).

alt text

alt text

In case you can’t view the above at full size, here are the source files full size:

Desktop: http://braincrook.com/wp-content/uploads/2015/04/Untitled2.png

Surface 2: http://braincrook.com/wp-content/uploads/2015/04/Screenshot-9.png

Check quality settings per platform, especially whichever one is default, since this doesn’t appear to be the texture import size by platform.

Edit → Project Setting → Quality. The little arrows at the bottom of the options under each platform allow each to be set to default for the selected quality.

Then check the texture and object settings.

It could also be due to the massive hardware differences between a PC(CISC x64/X86) with discreet hardware and the Tablet (ARM/RISC) with non discreet hardware(i.e. no physical graphics processor separate from the bus).