Why does specular highlight ignore vertex position?

I’ve created a material in shader graph. The vertex position is controlled by a gradient noise. The setup is the same as in this tutorial: Making a Water Shader in Unity with URP! (Tutorial) - YouTube

The vertex position by gradient noise clearly works on the material except for the specular highlight which looks like it’s on a flat plane. It’s like the highlight completely ignores the vertex position offset.

I’ve tried changing various lighting settings and settings on the mesh renderer as well as on the light source to no avail. Does any one know why this is happening and/or how it can be fixed?


While the position of a vertex or fragment does play a role in the lighting, much more important is the surface normal which describes the surface angle \ orientation