Why does the 'Edit Script' button not open any external editor?

Hello everyone, and thanks for wanting to help. I am completely new to Unity and am following the ‘roll-a-ball’ tutorial, and I am stuck on the step that involves editing a C# script.

I created a C# script, get the preview, but I cannot edit it. I have tried all the methods (gear menu, double click, etc), and while the option to edit is certainly there, no external editor actually opens up to let me edit the script. I checked under Unity>Preferences>External Tools and saw that MonoDevelop is selected, and since it is built-in I doubt that I have just neglected to install it during the Unity installation.

Any idea on what could be wrong? If you have the time and think that getting MonoDevelop to work is a waste of time, could you just jot down a quick guide for me on how to hook up a different editor to Unity? I am running the Mac version of Unity in case that changes anything.

Thank you very much in advance for your time and advice! :slight_smile: Sorry for asking such a newbie question, but the questions related to this issue that I found on the forums didn’t solve my problem.

try reinstalling Unity. as long as you save the scene and project first, no data will be lost. If the problem persists, try opening it with another editor or manually find the script (in the assets folder) and open it with monodevelop . If all else fails, try restarting

I run Unity on Ubuntu and have same problem. MonoDevelop is not installed by default, and auto download button is not working (wrong URL).
It’s really hard to make conection between monodevelop and unity work (to use it just as editor is possible).
My solution (so far): use https://www.sublimetext.com/ and Unity - Scripting API: . You can find there the same things as in monodevelop just no auto-completion :confused: . But sublime is better :slight_smile:
(installing monodevelop from apt first didn’t helped me, but I’m noob …)