Why does this happen?

I enabled something where this happens:
On the Scene tab, if you zoom into anything, it disappears as you approach it (but reappears if you back away)
It is really annoying, how do you disable it?

you are possibly stuck in “iso” view mode, click the centre of the widget in the top right of the editing 3d window, or the three parallel lines that say ISO on them