Why does this MeshCollider think it's half as thick?

![1]

As you can see in the image, the object (a rigidbody) sits halfway through the floor. This happens on both sides. It’s set to Convex. The mesh was created in Blender. Any ideas?

An interesting effect of using the “Scale Factor” on model import, it doesn’t affect penetration depth for MeshColliders. The engine thought my model was twice its actual size. I’ve adjusted the pen depth for now, but I’ll have to go and scale down all my models to use Scale Factor = 1.

Thanks syclamoth

I’m pretty sure since its convex : Convex If enabled, this Mesh Collider will collide with other Mesh Colliders. Convex Mesh Colliders are limited to 255 triangles.

Is there a special need to have this convex … ?