Why does time pass too fast when built, but not in the editor?

I am currently learning to program in Unity, and made good progress. Some time ago I already did a player controller, and it worked fine. But now I switched to using Rigidbody physics. So I update (in FixedUpdate) the characters movementspeed and set the Rigidbody.velocity accordingly. In the editor it works fine.


When I build the game, the character moves ridiculously fast. To start troubleshooting I made a Text UI Element to display my Rigidbody.velocity.magnitude. It shows the same, regardless whether I’m in play mode or in the standalone.

So I decided to also monitor the time passed using Time.time. In the standalone it goes up like 3 to 5 times as fast as normal, while timeScale REMAINS at 1.

Is there any mistake I could’ve made, which causes the time to rapidly pass while the timeScale is 1? If it is needed, I’ll post some code segments. But I honestly wouldn’t know what to post, since I’m pretty confident, that there is no mistake in it, since it runs fine in the editor. NOTE: in the editor my game runs with ~150fps while the standalone renders some 1.5k fps. But this ratio does not correlate with the factor by which the time runs faster.

this is due to frame rate because unity has a bit of over head making the fps drop slightly but when u build the application there is no over head,

an easy fix is to times the speed by Time.deltaTime and that should match up the frame rate

Okay, it seems like just literally posting this question has solved it… I wanted to make sure, it’s not a framerate-related issue, and changed my V-Sync mode in the nVidia control panel from “fast” to “on”, and also enabled V-Sync it in Unity, and everything worked fine.

Reverting those settings did NOT re-introduce the problem for whatever reason. The game runs fine now at high framerates.