Why does Unity 3.0 fail to start on OS X (Mac)

Why does Unity 3.0 fail to start on OS X (Mac)

Unity may fail for different reasons: needs a supported video card, sufficient memory and hard disk space to run. It also needs the Operating System to have the expected drivers, libraries and permissions.

Following is a list of common solutions that have worked before:

  1. Keep your computer up to date. Use the Software Update to find updates to software and hardware in your system.

  2. Kernel Panic. This can be caused by damaged or incompatible software or, in rare cases, by damaged or incompatible hardware. It is very very likely that in this case it is the latter what causes a "Kernel Panic" screen to appear. A common cause is your computer overheating because of dusty (or not working) fans.

  3. Elgato Turbo USB dongle. This installs some QuickTime components that cause Unity to crash. See http://forum.unity3d.com/threads/61754-Unity-3-crashes-on-startup. The Library that causes the crash is called Crusher.

In one rare situation, I actually had a file in my Library that was caching an absolute path to my user directory. This is a no-no. When I changed usernames, it broke and the program was crashing when I ran it.

Anyhow, the way I was able to tell: was by running the unity application from the command-line like so:


When it is run that way, you get "error spew" written to the terminal when certain low level things go wrong. It can help track down problems like that.

Are you on OSX or on OSX on a PPC machine?
Unity 3 stopped to support PPC machines in the editor completely, Unity 3.5 additionally removed the option to build players for PPC and pre 10.5 OSX

So if you are not on on an Intel OSX machine with 10.5+ you are out of luck