Why has Scene View orbit stopped working!?

I'm not sure if I've lost the plot here, but I cant seem to rotate my view around objects any more. When I press and hold alt whilst dragging, I get the same result as if I'm using the hand tool. When I press alt, the hand changes to an eye icon, but no matter what I do I can't seem to rotate the view. please help!

Something else worth mentioning with this is the transparent padlock top right of the axis sphere. The XYZ directions in scene view that also allows to change from perspective to ISO.
Clicking the padlock will lock the perspective and disable any orbiting etc.

ok i found the fix, you dont have to open a new project to fix it

the problem starts when you hold down right mouse button and then click left mouse button it will instantly put you “eye” mode and you cant do anything but zoom in

the fix is to click on the little play button at the top (looks like a button you would use on a video player) , then the scene will place you in some random spot… just click it again and presto , you’re right back where you were with perfect rotation

hope this helps

Hi,

I just had this problem and after 10 min of rage and upsetting research I just figured out that it just happen when you switch into 2D mode.
Don’t know how it happened for me but then just click the 2D button right between RGB button and volume button on top of the scene view.
That worked for me.
Hope this helps

I just had the same (or similar?) problem.

The fix for me was selecting an object, hitting the [F] key to focus on it, and then try navigating around my scene. It just worked after I Focused on an object. :slight_smile:

I just had a similar problem. I closed the SceneView window and reopened it, which seemed to fix it.

There is a little lock icon in the top right corner of the scene view. Unlock it and it should be OK,

For me, the solution was really embarassing:
One of my birds nibbled on the mouse wheel, and thus the middle mouse button wouldn’t work properly anymore. I had to get a Unity supporter tell me about it. :frowning:
How embarassing.

It's working again now, after I opened a new project. However I had already tried quitting the program and that didn't work

anyway, I'm sorted :)

Yeah, this is SUPER annoying. Switching between the hand and pan tools (q and w) did not fix it for me… but if you just create a new scene and then throw it away, that DOES fix it.

None of above solved my problem as it was not Unity’s fault… problem was between chair and keyboard. I had autohotkey script enabled which will rapid click right mouse button when it is held down. Check you autohotkey scripts if nothing above works.

just click on the lock button at the upper right corner of the scene view. actually scene view rotation is locked .

I have solved this problem by disabling “Gameobject” having Easy Water Shader.
I believe Animated Materials were causing the problem.

At the top right of the scene viewport, there’s a rotation GYRO with your y x and z directions. If it’s grayed out just click the lock icon to the top right. You may have accidentally tapped it.

There is a lock button right above the persp gimbal. Make sure it’s unlocked!

I have this problem … again … It has happened before and was resolved after installing new versions of Unity, but… seriously…

There’s a bug somewhere in there that will randomly cause orbiting to stop working and it has been an issue for ages. And please don’t ask me to press the lock on the gimbal. That answer has been given 15 times already and it’s not the problem.

I’ve done a diff on my entire project - no changes vs. when it worked. I’ve deleted UserSettings completely, no change. Restarted Unity, and the hub, no change. Created a new scene, no change. (And yes, I’ve checked the gimbal lock on and off multiple times, no change).

This is Unity 2021.2.5f1on OsX (Monterey)

I accidentally clicked a tiny little lock just aside the xyz rotation axis, unclick it to fix, hope i helped

111456-untitled.png

There is the pad lock Will Fix the issue.