Why is an empty iOS project building to 233mb in size?


I’m currently working on an iPad game and I noticed that when I built it within Unity, the Xcode project was approximately 300mb with an Xcode archive size of 136mb. I couldn’t account for such a large size (all of my textures are using PVRTC compression) so I tried building a completely fresh project (no assets, blank scene with one camera) and the Xcode project size is 233mb with an archived size of 97mb. According to Unity - Manual: Optimizing the size of the built iOS Player, you should be able to get it down to 12mb with DRM attached if you use the correct build settings.

Here are my current build settings…

I’m using Xcode 6.3 and I’ve tried changing the Xcode project format compatibility but there was no change. I’m running Unity 5.0.1f1 Personal/Free edition and I have Development build unchecked when I build. I’ve also tried changing the Target iOS version to 8.1 and it didn’t help either.

I’ve had a look through the project files and libiPhone-lib.a is by far the largest file (216mb).

Does anyone know what I’m doing wrong? Cheers for any help.

Hi. I think that this is bug… i have this problem too.
Even empty iOS project make 273mb size after build.