Why is animation not played completely when normalizedTime is 1? [SOLVED]

Hi.

I’m having troubles with playing an animation. I have a model with multiple animations and using legacy animations.

Because I want the models components to be at a specific position I play them by setting the normalizedTime to the desired value. Speed is set to 0 on start.
Now one of the animations work fine but the others are not played completely even if normalizedTime is 1. I also tried to set the time value to the animationClip’s length, without success. I can see the full animation if I look at the imported animations in the inspector. On other similar models everything works fine. I’m stuck.

I’d like to give more information but don’t know what could be relevant - let me know.

Can someone help me with this? Anyone had this issue before?

Thanks

Edit: It looks like the animations stop in the middle but normalizedTime is 1.

I solved this by recreating the animations and reimporting everything

Make sure you animations wrapmode is set to ClampForever. When a normal animation reaches the end it just stops immediately. ClampForever will keep the animation in the last keyframe even when the time keeps on running.

This is the only thing i could think of right now.