Why is emissive glow going to white?

I wanted to make a glowing material so I :

  • Used URP
  • Created a new Material using the simple lit shader because it also have the Emission Box
  • Checked HDR in my Render Pipline Asset
  • Applyed Bloom
    In the End I got the Glowing effect that I wanted except the problem is this only works for certain colors generally when the color picker is top right :

But When I Pick a color in the middle, to start things of the emission color and the actual color aren’t the same even thought they have the same RGB values :
the Color :


the emission :

And when I Increase the emission intensity it changes the color completely Turning it White :

(I tested with all different values of intenisty and Bloom and nothing changes)
I also Heard that tonemapper can fix it but it didn’t do the trick for me so what am I supposed to do to get the appropriate result ?

Idk,much about unity editor but on the last slide your emission map has purple on the outside and white on the inside, if you can somehow swap those two colors maybe that will help. sorry not to be much help…

This is an effect of tonemapping. The scene is rendered in HDR, which cannot be displayed on a screen directly, and needs to be converted to the actually displayed color using tonemapping. In addition, the bloom is added to the overexposed pixels.

I don’t use URP, so just search for tonemapping in URP.

This is an intended behaviour.
If you only want to render a material that is displayed with a plain color, don’t use lit shaders with emission, but some unlit shader.

If you want the “bloom” glow, you could also turn down the bloom threshold - but then everything will glow.
Another option is to create a comppletely custom render pass in which you render the glowing objects and apply the bloom separately from the rest of the scene, then blend in the result.

I’m Just answering this in case someone has the same problem as me in the future and finds this discussion.
After a lot of research testing and really just changing values adding things deleting other things and all, I’ve come to undestand some stuff.

  • First, it is impossible to keep the color 100% intact while making it glow from what I understood it’s to give a realistic effect so the color WILL go white upon reaching a certain value of intensity
  • Like I said before the colors at the top Right corner of the color picker really aren’t affected much by this as they Glow exacly how they should without any problem, but the More you go down the color picker (so the color becomes darker) it becomes more difficult to give a glow effect (because darker colors aren’t supposed to glow for example the black color isn’t affected by the emission at all and you can’t make a black emission) so it becomes whiter instead to be able to give it any sort of glow and when you go left of the Color picker it becomes whiter because it’s adjacent to the white color in other words it converges to the white color
  • Still if you want to have some sort of glow for darker colors what I found out is, by using the tonemapper and playing around with the intensity values (you have to increase it by a LOT, but to not effect the other elements of the scene you can creat a separate overlay camera and make it render that layer only) and you should also use the tint propertie of the Bloom to help you get better results.
    Here is an example with a slightly darker color that I somehow could get to glow using the Tips I listed before :
    Pre-Effects :

    Post-Effects (Bloom, toneMapper, emission with a simple lit shader material) :

Tips :

  • When Using the The Emission don’t increase the intensity (1 at max) just choose a color and check it’s checkbox :
  • Pick the Color by using the color picker instead of it’s RGB values (for some reason they give different values and the Color picker one is more accurate)
  • Using ToneMapper Mode : ACES gives the best results from what I’ve seen :