Why is my fresh unity 4.2 crashing on Windows 8?

I Have just installed unity 4.2 on my new laptop with windows 8 and its continually crashing. If I attempt to open an existing project unity instantly crashes, if I try and make a new project and import some standard assets, unity instantly crashes. If I make a new project and import no packages then unity will open, but will crash if I try and import a package, import an asset or create a game object.

My Laptop is a new Toshiba Satellite p50t-A01c with windows 8 64bit. The drivers are fully updated. I have replaced the standard HDD with a 250GB SSD (I don’t see why that would matter though).

I have also tried unity 4.1.5 and 3.5 with similar results.

When I reopen an empty project after a crash (after attempting to import terrain assets) the error log reads

Automatic import for 'Assets/Standard Assets/Terrain Assets/Terrain Textures/Cliff (Layered Rock).psd' was disabled because the asset importer crashed on it last time.
You can use 'Assets -> Reimport' to enable automatic importing again.

I Have also recieved an error log linking to http://support.microsoft.com/kb/976038

which is a hotfix for windows 7 and below operating systems.

Any idea why this error may be happening? And Where would unity be saving the logs from these crashes?

Turned out it was a dx11 issue, by forcing unity to run in dx11 mode with a command line argument I was able to fix the issue. I just put -force-d3d11 on the end of my unity shortcut.

I’m guessing that win8 dx11 isn’t fully compatible with dx9?

The issue is connected with integrated Intel 4600 gpu . Seems like Windows 8 Intel drivers are not working well with Unity 4.2.

I had the same problem when importing assets.Running Unity with dedicated Nvidia card fixed it.

For what it’s worth, I got the following from Unity support:


You are running Unity on a graphics card known to create similar problems for some of our users. Make sure you have DirectX 9.0c installed, have the latest drivers for your graphics card and have not disabled 3D acceleration in display settings.


mr. decency’s solution worked for me.

I had the same problem in 4.3.4 after I had to remove my dedicated video card and this fix worked for me too.