Why is my image's checkered background showing when it's supposed to indicate that it has no background


I’ve seen this question asked several times in this forum, but none of the suggestions in the answers seems to reflect the current Unity Editor UI (I’m using version 2019.3.7f1).

I have an image of chess pieces, which I have spliced to use on a 2D chess board. The original image has no background. However, when I place it in a game object, it shows the white and grey checkered grid behind the piece. How can I fix this so it only shows the piece?

I’ve attached the original image with all the chess pieces, as well as an image of the scene editor with one of the pieces, with the sprite’s settings for referrence.

It isn’t actually a PNG. It’s just got a checkered background.
You might want to run it through an image editor and remove the background and then export it as a .png.