Why is my mesh showing the model geometry?

Hi guys,
First off, I’m sorry if this has been asked, I tried to search for it but I couldn’t find anything. I created a drum clip model for an assault rifle in Blender, exported it as an .fbx file, texture it in Substance Painter, and then imported it into Unity, but some of the faces are highlighting the geometry, here’s what I mean:

Do you see how it almost looks like a weird circular pattern of triangles? How can I get rid of that? Thank you in advance for your help.

Try editing the model so that it uses quads instead of n-gons.
N-gons are faces with more than 4 edges.
Unity doesn’t like n-gons.

Having same question

You can actually import blender files directly into unity. I find Blender’s “save copy” function to be particularly useful for this workflow.

In any case, make that your quads are as coplanar as possible (all 4 vertices lying on roughly the same plane). You may need to edit your mesh to achieve this condition. In addition, setting the shading to smooth in blender will make the geometry much less visible in unity.