why is my scroll wheel zooming in large increments in editor mode

I upgraded to version 4 and now in editor mode my scroll wheel zooms in/out in very large increments as compared to before the upgrade. I am using windows-7. Is there an adjustment for this?

If you select your object (by double clicking on it in the hierarchy) your view and zoom increments should be automatically adjusted. It doesn’t work so well however if your objects are very small.

You can also select and object and press F. But still not good when working with small objects, especially when working with VR / AR that works with small scales. The best thing I have found to work around this is to add everything as a child to a game object and temporary scale that object up a bunch. But Unity should definitely add an option for this. Or adjust depending on how close you are top the object, as all other 3D programs.