Why is the mesh is smoothed out like this?

When I import my blender model, the mesh is automatically smoothed out. I export it as a fbx file, then import it into Unity. In blender, I turn off smooth shading, and set my blender material’s specularity to low. When I render it in blender, it looks fine. But when I import it into Unity, the mesh is smoothed out.

Why does the mesh get smoothed out like this?

Check the import settings for your mesh. There is a “Normals [Calculate, Import]” option with a threshold for smoothing. Dial that slider down to zero and re-import, set your mesh to calculate and re-import.