Why lights turn on when I approach them, after using Lightmapping ?

Hello guys !

In my scene, I put some point lights and use them for just backing ambient occlusion.
It make well, I enjoy ^^

But, after that, I put a First Personnal Controller and when I’m far from lights, they are switched off. When I approach them, they turn on.

I don’t know why …

Can we solve this problem ?

Thanks you all.

First of all make sure you mark your point lights and static objects as static. Do do so you’ll need to tick the “static” box located in the top right section of the inspector. Once your done, bake the scene again.

Now if that doesn’t work, then select all your point lights and look in its inspector. There should be a option panel at the bottom where it has the Automatic option enabled. Make sure you change it to static then bake the scene again.

If none of theses work, then… Go to your light mapper panel, and before you click bake, select all your objects that you want to be baked then bake the scene. I hope this has helped you :slight_smile:

Hello Myslaak.

I tried but nothing work.

All my objects and lights are static.

If I select all my objects that I want to be baked, or not selec, it changed nothing …

I looked for the option panel at the bottom’s light Inspector. I have “Render Mode”, “Culling mask” and “Lightmapping”. In “Lightmapping”, I can choose RealtimeOnly, Auto or BakedOnly. I tried to change it and bake the scene again, it doesn’t work …

I will search again …

Thank You !

EDIT : I founded :slight_smile:

I juste have to turn off all mys lights. The Lightmappng also baked lights. Then, I don’t need any lights … I just turn off.