Why my model fly after adding the timeline....

Problem (I just use the video from my youtube account):
https://www.youtube.com/watch?v=1Dg-kY1mEQs

I just added a timeline and that's how things turned out, and the model just kept flying forward. But it's good in the preview. And I didn't use any script yet.

DarkKnight Prefab:
9050920--1250641--upload_2023-6-2_0-59-37.png

timeline:
9050920--1250644--upload_2023-6-2_1-0-23.png

stabFront:
9050920--1250647--upload_2023-6-2_1-1-15.png

stabbedFront:
9050920--1250650--upload_2023-6-2_1-1-46.png

Does anyone have thoughts? I have no idea about this bug right now. It's not impulse accumulation. I set the material to zero friction

我修了一晚上来来回回重做了好多次了还是修不好………
有没有跟过傅老师Dr.Fu课程的大佬帮帮忙啊,我现在对这个bug毫无头绪。不是冲量累积,material我调成零摩擦了
救救孩子……(ノДT)9050920--1250641--upload_2023-6-2_0-59-37.png 9050920--1250644--upload_2023-6-2_1-0-23.png 9050920--1250647--upload_2023-6-2_1-1-15.png 9050920--1250650--upload_2023-6-2_1-1-46.png 9050920--1250641--upload_2023-6-2_0-59-37.png 9050920--1250644--upload_2023-6-2_1-0-23.png 9050920--1250647--upload_2023-6-2_1-1-15.png 9050920--1250650--upload_2023-6-2_1-1-46.png

Is there something to do with Physics? If the sword and enemy both have non-trigger colliders, Physics would depenetrate them.

I don't know... I adjusted the physical material of the character to zero friction. The sword's collider is trigger one, but the enemy's is not, and I don't think it should be.

In addition, I tried to increase the quality of the rigid body and nothing changed. The same goes for changing models. Normal battles can still go on without executing the timeline, but I think there may be something wrong with some of the settings of timeline.