Why sprite are semi transparent

Hi today I notice that my background sprites are semi transparent. I open my sprite with Photoshop and the texture was fine with 100% opacity. How to make it to transparent only the parts that must be and the other color parts not trasparent.29863-tansparent.png

I found how to remove the transparency. In the inspector view I change the format of the sprite to truecolor and the transparency goes off, don’t know why but works :slight_smile: now the only the transparent area is transparent.

True color must be use only if it’s the only type of Format that allows your image to render correctly, because true color is the heavier format, for more control you have to select “Texture Type = Advanced” and then you have to find what type of format functions better for your sprite.

Here you can see the configuration that i used for an specific image, in this case only trueColor worked.

Check opacity of the color on Unity. If not 100%, you will get transparency.
I think you will need multiples sprites over each other, alternating the transparency of each to make only some areas transparent.

This is still a problem in Unity 4.6.5. It only seems to happen with 16-bit sprites with alpha (RGBA 16), which happens to be the default compression format when you choose “Compressed” in the inspector on some platforms. So it looks to me like it’s a bug in Unity’s 16-bit color conversion algorithm. The only solution seems to be to either use Truecolor (big waste of space) or force another texture compression format such as DTX5 on most platforms or PVRTC if on iOS. To get the option to set your compression format, you must change the sprite to type “Advanced” in the inspector first.

Sloppy…