Why URP lit shader gives shadow artifacts?

The positive X face of the cube has these weird shadow artifacts.

When I toggle “Receive Shadows” off in the material they disappear.

Steps I took:

  1. Created a new project (3D template)
  2. Imported Universal RP from the Package Manager
  3. Created new URP Asset
  4. Assigned that asset to the Scriptable Render Pipeline Settings slot in graphics settings
  5. Created new material and assigned it URP/Lit shader
  6. Put that material to a cube

Unity version 2020.3.6f1

macOS Big Sur version 11.2.3


Sorry for the late reply, but may be useful for someone else.

It seems to be the same problem as here:
(Didn’t try it myself. The recommendation is to vary Shadow bias parameter.).