Why won't my Unity game run? Missing assembly reference but have all standard assets installed?

Hi, I’m a new user trying Unity, and forgive me if this is a dumb question that can easily be solved with a single button, but I have been pulling my hair out trying to figure out why I keep getting these errors. Here is a screenshot:

The errors read:

  • “Assets/GE Common Assets/GE Touch Joystick/CrossPlatformInput/Scripts/Editor/InputAxisScrollbarCI.cs(6,31): error CS0246: The type or namespace name `InputAxisScrollbar’ could not be found. Are you missing a using directive or an assembly reference?”
  • "SpeedTree materials need to be regenerated.
  • “Assets/GE Common Assets/GE Toggle Full Screen/Scripts/GE_ToggleFullScreenUI.cs(60,69): warning CS0618: UnityEngine.RuntimePlatform.OSXWebPlayer' is obsolete: WebPlayer export is no longer supported in Unity 5.4+.'”

I suspect maybe I have some outdated assets in my folders? In that case, how do I delete those assets? I have uninstalled Unity once and the assets stayed. As for when it asks me if I’m missing assembly references, I literally checked all the boxes of the standard assets upon creation of my project. If I try to import them again, a message pops up and says all assets have been imported. I hope somebody can help me figure this out, because all my friends are having fun with their assets and I am going to flip sh*t if this goes on any longer.

Because RuntimePlatform.OSXWebPlayer is Obsolete as it says in the error message
and Screen.lockCursor

Unity - Scripting API: Screen.lockCursor is also obsolete

There is a work around for Screen.lockCursor if you are willing to code.

Cursor.lockState

Here is a visual understanding as well.


I am currently trying to find a solution for the game pause ability which use to be done through the obsolete OSXWeplayer.
The above link should explain how to work around locking the mouse.

If you post the script I could try to edit it for you.
The script I need to see is

GE_ToggleFullScreenUI.cs

Assets/Unity-Logs-Viewer/Reporter/Reporter.cs(2013,47): error CS0619: UnityEngine.RuntimePlatform.OSXWebPlayer' is obsolete: WebPlayer export is no longer supported in Unity 5.4+.

Ok, is Obsolete… but Assets/Unity-Logs-Viewer/Reporter/Reporter.cs is a Unity cs file! I did not write it myself.

I had the same error caused by facebookSDk, I just downloaded the update and the problem solved!!