Why won't Unity3d run?

I recently installed Unity 4 but had to uninstall it because it kept crashing to desktop in my project(CTD bug reported and successfully reproduced by Unity Tech). I had no other option but to revert to Unity 3.5 so I installed 3.5.7 this morning and when I try to run it nothing happens…nothing (no services or applications running in task manger). There is just a little load icon for a couple of seconds, then nothing. I have tried uninstalling many times, re-installing…tried installing 3.56 but this has the same issue…I’ve also restarted PC many, many times…

…but nothing. Anyone any ideas?

Things Ive tried:

  • Installing & re-installing 3.5.6
  • Installing & re-installing 3.5.7
  • Rebooting -over and over
  • Cleaning registry
  • Checking for viruses
  • Making sure Unity can see through
    WIndows firewall
  • Uninstalling the Asset Server &
    Monoscript manually.
  • Updating GFX drivers
  • Rebooting some more

So far this year, myself and Unity have had a bad relationship…and to think that last year was so good.

I should also mention :
Windows 7 64bit
8gb ram
AMD 6900 GFX card

Re-installed windows 7.

3 weeks of re-install hell, but it now works again…

Are you trying open a specific project? sometimes i got a error like this and deleting cache folder inside library folder of my project resolve.