Will asmdef/package.json update be backported to LTS version?

Things like conditional asmdef include, GUID instead of string reference, the latest asmref etc. Can I use it on my packages without making it unreadable by versions like 2018.3/4LTS assuming that it is updated to the latest possible minor version of it? I am afraid that if my asmdef contains a bunch of GUIDs instead of string that would limit coverage to only later version.

No, these features won't be backported.
[quote]
What are the main issues that an LTS stream will address?
The LTS version will not have any new features, API changes or improvements. It will address crashes, regressions, and issues that affect the wider community, console SDK/XDK, or any major changes that would prevent a large section of users from shipping their game.
[/quote]
https://blogs.unity3d.com/2018/04/09/new-plans-for-unity-releases-introducing-the-tech-and-long-term-support-lts-streams/

2 Likes