Will the Unity Package Manager support version ranges?

I am loving the new Package Manager and can’t wait to see it more fully built out and used for more than just Unity made packages. Will the package manager ever support version ranges like other popular dependency managers, such as NPM? There are trade-offs to consider when adding a feature like this. NPM can be a real headache because of version ranges.
Does/will the Unity Package Manager support version ranges?

Does/will the Unity Package Manager support version ranges?

I have just made some some attempts to investigate the issue (with Package Manager 1.9.3 on Unity 2018.1.0f2) and currently see no sign of support for tilde- and caret-ranges. I hope they will eventually be added.