Windows Mixed Reality scene won't play to headset


I’m building a scene for a Windows Mixed Reality headset, using the Mixed Reality Toolkit. I have MR portal, SteamVR, and Windows Mixed Reality for SteamVR all installed, and the scene and project both set up for MR.

I’ve tried out the same scene on a different computer, and it has no issues there, but on this one the Unity scene won’t play to the HMD. It displays in the play window and shows the perspective of the headset as it’s tracking, but in the HMD, all I see is the empty white ‘default’ room.

No issue with playing built apps or Cliff House.

Any advice?

Hello there,

I’ve had this problem a few times before, where apps would run without issues with the HTC Vive or OCULUS, but wouldn’t use the headset when in Windows Mixed Reality.

These might help you:

  • Open steam and select Steam VR. Go to properties, and change the branch to accept beta builds.
  • Open SteamVR (The program, not the app on Steam), go to General, and enable “SteamVR Home Beta”
  • On Windows 10, go to settings. Search for “Developer”. Select “For Developers.” Enable “Developer mode”, and let windows download what it needs.

These steps solved most of our issues with Windows Mixed Reality on the Samsung Odyssey. Hopefully it can help you as well.

Otherwise, there’s always the classic unplug/plug everything back in, try different USB ports, etc…

Hope that helps!



No luck… Now it puts me into the SteamVR Home room rather than the loading screen, but it still doesn’t show the Unity scene when it’s played.

Having the same issue did you solve this?