Wolrd Unit size ?

I made a 1x1x1 unit cube [meters] in Max, and I am trying to tile these cubes (each with their own materials) so that there are no gaps…

However, when I position cube A at 0,0,0 and cube B at 1,0,0 the world units are not in meters. In actuality its close to 39.5 something…

So, what are the units of world space, or how do I create the conversion into meters ?

Unity’s scale by default, because of the physics engine, is one Unit = 1 meter. However, The scale can be whatever you like. If you want your imported mesh to be in meters, You will have to make sure it is scaled correctly, either in your modelling app, or in Unity’s FBX Importer.

What is the FBX importer scale set to on your incoming mesh? Try setting it to 1.
My understanding is that there isn’t any unit for the Unity world.

Check to make sure that your Max settings are correct. The default Max setting can give odd results. Go to > Customize > Units Setup… Click the radio button for Metric in display unit scale and set the drop down to meters. The set your system units setup to 1 = 1 cm. I use those settings and export with no additional scale in Max. You can’t really change the readout on the Unity Inspector to say meters, but just know that with these settings you should be in good shape. Build a 1m cube in Max and then a 1 unit box in Unity. They should be the same size.

If that doesn’t work, there might be a problem with your exporter. Another issue that has come up some times (not sure if it is a bug) is that I need to freeze my Max shapes before export. I’ve just started to do this to all of them after I got a really odd shape once.