[WSA] [UWP] [Crash] Can some one explain the cause of this error Access violation writing location 0x0000011B86000004.

Hello I am currently working on a project which involves two scenes in the project. Lets call them phase1 and phase2.

The app launches with the scene phase1, user fill if there details and then proceed to phase 2.
In the phase2 scene there is an option for user to go back to phase1, but as soon as they try to do that we get an error in visual studio and the app crashes for the user.

Following error comes up while debugging.
Exception thrown at 0x00007FF9F806DF6B (UnityPlayer.dll) in AppName.exe: 0xC0000005: Access violation writing location 0x0000011B86000004.

Following is the call stack of the same.

>    UnityPlayer.dll!LightmapSettings::RemoveLightmaps(int)    Unknown
     UnityPlayer.dll!DidUnloadScene(int)    Unknown
     UnityPlayer.dll!RuntimeSceneManager::UnloadAllScenesWithoutDestroyingGameObjects(void (*)(class UnityScene &))    Unknown
     UnityPlayer.dll!UnloadGameScene(void)    Unknown
     UnityPlayer.dll!LoadSceneOperation::PlayerLoadSceneFromThread(void)    Unknown
     UnityPlayer.dll!LoadSceneOperation::IntegrateMainThread(void)    Unknown
     UnityPlayer.dll!PreloadManager::UpdatePreloadingSingleStep(enum PreloadManager::UpdatePreloadingFlags,int)    Unknown
     UnityPlayer.dll!PreloadManager::WaitForAllAsyncOperationsToComplete(void)    Unknown
     UnityPlayer.dll!PreloadManager::UpdatePreloading(void)    Unknown
     UnityPlayer.dll!ExecutePlayerLoop(struct NativePlayerLoopSystem *)    Unknown
     UnityPlayer.dll!ExecutePlayerLoop(struct NativePlayerLoopSystem *)    Unknown
     UnityPlayer.dll!PlayerLoop(void)    Unknown
     UnityPlayer.dll!metro::MainLoop(bool)    Unknown
     UnityPlayer.dll!UnityPlayer::AppCallbacks::DoPerformUpdateAndRender(void)    Unknown
     UnityPlayer.dll!UnityPlayer::AppCallbacks::_AppThreadImplementation(void *)    Unknown
     kernel32.dll!BaseThreadInitThunk()    Unknown
     ntdll.dll!RtlUserThreadStart()    Unknown

Can anyone please help me with the cause of this? I have also tried to load an empty scene From the phase2 scene but I get the same error.


LightmapSettings.lightmaps = new LightmapData[0];

before loading the scene fixes it.

From Unity:

Hey, we just fixed this. The fix will be in 2020.3.17f1 and 2021.1.18f1. It turned out to be more gnarly than expected as it was caused by a bug in the C++ compiler.