WWW class not working in Unity 2017

Hello guys !

With the new update of Unity 2017 “WWW” class always returns “404 Not found” error.

It worked fine with previous version so if someone has an idea it would be great because I’m starting to go crazy with this one…

For additional information :

  • The application is authorized via the firewall :
  • The code I’m using (which work damn great on previous version) is

// ***** We are in a method with this signature : private IEnumerator verifyServerURL() *****

string URL = "www.myserver.com/myscript.php"; // This gives me my page in Chrome (so it's reachable)

Debug.Log("Connection to [" + URL + "]");

// Preparing the web form

WWWForm form = new WWWForm();

form.AddField("Action", "dosomething");

// Send the form to the server

WWW w = new WWW(URLtoServer, form);

alertField.text = "Request sent, please wait...";

// Wait for the result

yield return w;

// Result arrived

if (w.error != null) //ERROR


Debug.LogError("Server answer : " + w.error); // Always throws error HERE !

// Clear the form



What’s wrong ?

Can someone test on his side ? (Some people reported me this problem too so it’s not just my installation or anything)

Thank you in advance for your messages

Saw you solved the question on the Unity Forum. Here is the link to the solution :slight_smile: