XCode 4.4.1

I would like a final answer on Unity 3.5.5 and XCode 4.4.1. I am still running OSX 10.7, so I am not worried about ML. I mainly want to know if I can upgrade to XCode 4.4.1 and not have any problems. If there is even one small problem I will just wait. I have read postings some saying there are problems other not, but many of them are mixed with things about ML and I don’t care about that yet.

This is not relevant anymore because I am on the latest of everything.