xcodebuild skipping Unity4XC.xcplugin "because it is not compatible with this version of Xcode"

I haven’t been able to complete a build ever since updating to Xcode 8.

When I run xcodebuild, I get the following error:

xcodebuild[3596:28722] [MT] PluginLoading: Skipping plug-in at path '/Users/buildserver/Library/Application Support/Developer/Shared/Xcode/Plug-ins/Unity4XC.xcplugin' because it is not compatible with this version of Xcode.

I’ve confirmed that the DVTPlugInCompatibilityUUIDs is set correctly, and I’ve ensured that my symlink in ~/Library/Application Support/Developer/Shared/Xcode/Plugins/Unity4XC.xcplugin is pointing to the correct spot.

Is there anything else I should check?

I fixed my problem by just deleting the symlink at ~/Library/Application Support/Developer/Shared/Xcode/Plugins/Unity4XC.xcplugin.

To delete legacy Unity4XC.xcplugin
$ rm ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins/Unity4XC.xcplugin