XR controller (action based)_

I am trying to add the components XR controller (action based), yet they don’t show up in the list. I have the XR toolkit, but the only one showing up is XR controller recorder.

The script ActionBasedController is in this file path in unity projects (or should be depending on version) Packages/com.unity.xr.interaction.toolkit/Runtime/Interaction/Controllers/ActionBasedController.cs

Double check you have the XR Interaction Toolkit package, if you do but the script isn’t in the path above try reimporting the package

image
There is this script called action based controller, yet it is empty. Also, I see everyone using the XR controller (action based) component, but this might be version differences. Also for the project I am using Unity 2022.3.20f1
As for the interaction toolkit, I currently have the 3.0.1 version. I tried going back to the recommended 2.5.4 version, but that didn’t do much.

I just found the path you provided. I did find the actionbased controller script, I think. I copied it into the empty I made for the controllers. It is however deprecated om version 3.0.0. I also don 't get the preset from the starter assets when I try to select a preset

Ok, I tried fiddling around with versions and things, and now for some reason it is showing up and working. Thank you so much for your help.