Your app includes non compliant SDK version

I got a message from Google Play Store:

Your app includes non compliant SDK version

Your app XXX version code 129 includes SDK com.unity3d.ads:unity-ads or an SDK that one of your libraries depends on, which collects personal or sensitive data that includes but may not be limited to Advertising ID, Android ID identifiers. Persistent device identifiers may not be linked to other personal and sensitive user data or resettable device identifiers as described in the User Data policy.

Starting from August 29, 2022 midnight (UTC), new app releases containing the SDK version(s) that do not comply with the User Data policy may be blocked from release. You may consider upgrading to a policy-compliant version of this SDK that does not include the violating code if available from your SDK provider, or removing this SDK from your app.

According to the information provided by your SDK provider, you may consider upgrading to 4.0.1. Please consult the SDK provider for further information.

ACTION REQUIRED: Upload a new compliant version AND deactivate the noncompliant version.

I just followed this web page:
https://docs.unity.com/ads/GoogleDataSafety.html#:~:text=Starting%20April%202022%2C%20Android%20developers,SDKs%20such%20as%20Unity%20Ads.

7 Likes

I have the same problem here. I'm using version 4.1.0 of unity ads.

The latest version of unity ads 4.2.1 fix this problem? There is nothing related to this subject in the change logs.

https://docs.unity3d.com/Packages/com.unity.ads@4.2/changelog/CHANGELOG.html

1 Like

We got the same message on our last build. We are not using Unity Ads Package directly but Google Admob mediation installs the latests 4.2.1 version with the external dependency manager. The thing is why we are still getting this SDK warning using a higher version than the suggested 4.0.1?

1 Like

We had the same issue yesterday when uploading a new build on several attempts.

Would be great if the Unity team could chime in soon and give us some assist on this, we can't update our apps or they will get removed by the date suggested above.

I also faced the same problem. Moreover, I need to completely change my ADS script.

I get the error "The type or namespace name 'IUnityAdsListener' could not be found".

If you know an easy solution, I'd appreciate it if you could help, because I'm pretty new to this stuff :)

Hello, I have the same problem, I don't use unity ads but I do use IAP.

1 Like

same issue here, im using unity ads 4.1.0 which is newer than 4.0.1

Same here. I'm using Unity Ads 4.2.1 and I have followed instructions here:

https://docs.unity.com/ads/GoogleDataSafety.html#:~:text=Starting%20April%202022%2C%20Android%20developers,SDKs%20such%20as%20Unity%20Ads

[quote=“Kapteeni-Studios”, post:8, topic: 886453]
Same here. I’m using Unity Ads 4.2.1 and I have followed instructions here:

https://docs.unity.com/ads/GoogleDataSafety.html#:~:text=Starting April 2022, Android developers,SDKs such as Unity Ads
[/quote]

thank you but What should I do with these instructions? I updated the SDK. The problem I mentioned has occurred. For the solution, I need to completely change my ADS script and I don’t want to change it because it will take a lot of time and I will encounter more “bugs”. So I need a more logical solution.

Anyone found a solution yet? Do we need to update to Unity ads 4.2.1 and update our scripts? Can someone from Unity please chime in with a proper solution?

[quote=“SandJewel”, post:10, topic: 886453]
Anyone found a solution yet? Do we need to update to Unity ads 4.2.1 and update our scripts? Can someone from Unity please chime in with a proper solution?
[/quote]
i am still waiting…

Same, still waiting to hear back on a resolution to this & more threads on the topic.

[quote=“SandJewel”, post:10, topic: 886453]
Anyone found a solution yet? Do we need to update to Unity ads 4.2.1 and update our scripts? Can someone from Unity please chime in with a proper solution?
[/quote]

I have updated to Unity Ads 4.2.1 and I still get the error. No solutios yet as far as I know.

We're experiencing the same issue, too. As far as we understand, Google Play shows an error for the old release version that was used before. Because our app version 68 is live right now.

8252436--1080000--Screen Shot 2022-07-04 at 13.42.33.png

7 Likes

Humm I'm sure my version is above the required 4.0.1 but I'm still getting the error, any news on that?

Same here

Is it still possible to update your apps in the play store with this this warning since it states "Starting from August 29, 2022 midnight". So we can carry on updating apps with the non compliant SDK versions until 29th August?

Same here, I have updated to 4.2.1 and I still get the error.

I also received this error message. Check your releases for internal testing and closed testing. In my case, the old version of the application was still used there, now I'm waiting for verification to remove the old version from there.

1 Like

[quote=“FMGdev”, post:14, topic: 886453]
We’re experiencing the same issue, too. As far as we understand, Google Play shows an error for the old release version that was used before. Because our app version 68 is live right now.

[/quote]
[quote=“xdprint”, post:19, topic: 886453]
I also received this error message. Check your releases for internal testing and closed testing. In my case, the old version of the application was still used there, now I’m waiting for verification to remove the old version from there.
[/quote]

I think they are both right on the money. We had the same issue and ended up finding a very old testing build lurking around (still active as in testing) thanks to xdprint.

Also waiting for the results, but will try to update